Vizpin Mandatory Update

Vizpin Update (Mandatory Update)

An update of Vizpin (v.5.6.4) is now available on Google Store and IOS Apple Store.  It’s important to update your device before oct 14th or you will no longer be able to use the app.

This is important for after-hour access users. We want to prevent any members locked in building on Oct 14th because they forgot to update their device.